Voice Calling Issue

Incident Report for Blue Arc IT Solutions

Resolved

Monitoring has indicated that this issue is resolved. Please reach out should you still continue to experience any issues.
Posted Jul 07, 2025 - 15:01 AEST

Monitoring

The upstream provider has confirmed this is resolved but we'll monitor to confirm.
Posted Jul 07, 2025 - 11:47 AEST

Identified

Confirming our upstream vendor has identified a problem with the Microsoft Teams integration. Calls made with, or received with Microsoft Teams are impacted. Use alternate means of contacting us for support issues (Chat, Email, Portal etc.). Restoration ETA unknown at this time.
Posted Jul 07, 2025 - 08:59 AEST

Investigating

We're looking into a situation where we're seeing inconsistent voice calling behaviour across some clients and some services.
At present it seems to be affecting Microsoft Teams calling primarily but we'll update as soon as we know more.
Posted Jul 07, 2025 - 08:45 AEST
This incident affected: Client Engagement (Inbound Telephone) and Cloud Services (Blue Arc Connect Telephone System).