Intermittent call issues affecting Teams Voice

Incident Report for Blue Arc IT Solutions

Resolved

This incident has been resolved and calls are working as normal.
Posted Sep 08, 2025 - 09:06 AEST

Investigating

Our upstream provider is having intermittent issues with calls to queues where users have external numbers. This is affects anyone using Teams softphone.
Posted Sep 05, 2025 - 10:14 AEST
This incident affected: Client Engagement (Inbound Telephone) and Cloud Services (Blue Arc Connect Telephone System).