VoIP Outage

Incident Report for Blue Arc IT Solutions

Resolved

We've been monitoring closely for the last 24 hours and by all metrics this is resolved. Please reach out if you're continuing to have difficulty. Kudos are due to the engineers involved dealing with a complicated and shifting threat landscape.
Posted May 06, 2025 - 09:54 AEST

Identified

Our upstream provider is being affected by a Distributed Denial of Service (DDoS) attack that began at approximately 9:00 AM on Sunday, 4th May 2025. They have put in place advanced protections and workarounds that are minimising the impacts, however there may still be occasional issues such as failed call delivery or temporary registration loss. These issues should be rare and will only be temporary in nature.
Posted May 05, 2025 - 11:13 AEST

Investigating

We are seeing reports of call quality and connectivity issues. This is being investigated upstream.
Posted May 05, 2025 - 09:42 AEST
This incident affected: Client Engagement (Inbound Telephone) and Cloud Services (Blue Arc Connect Telephone System).