M365 Outage

Incident Report for Blue Arc IT Solutions

Resolved

The incident has been resolved. Microsoft have reverted a recent code change that caused the issue.
Posted Mar 02, 2025 - 09:37 AEDT

Investigating

We're observing authentication issues globally with Microsoft 365 services.
Posted Mar 02, 2025 - 08:20 AEDT
This incident affected: Cloud Services (Microsoft 365).